You can sign up to get a daily email of our articles, see the Mailing List page!
Anyone able to run X4: Foundations GOG version on Arch Linux?
Rooster 12 April 2020 at 6:53 pm UTC

I'm getting this error:

Running X4: Foundations
./X4: error while loading shared libraries: libssl.so.1.0.0: cannot open shared object file: No such file or directory

Avehicle7887 12 April 2020 at 7:45 pm UTC

You need to install the older version of libssl - in this case 1.0.0 (most distros ship with both 1.1.0 and 1.0.0). Also note that installing one might ask you to remove the other as normally they don't coexist system-wide.

Alternatively you could place that library in the game's folder and run the game using the LD_LIBRARY_PATH environment variable. This way you can run the game without modifying your system, personally I prefer it.

Last edited by Avehicle7887 on 12 April 2020 at 11:35 pm UTC

Rooster 13 April 2020 at 6:18 am UTC

Thanks, solved by installing the openssl-1.0 package.

beko 15 May 2020 at 12:51 pm UTC

I solved this on Fedora by dumping a copy of libssl.so.1.0.0 and libcrypto.so.1.0.0 to X4_Foundations/game/lib where the game picks it up. This way I don't screw with my system lib by downgrading openssl. This works for most problems like this:

 beko  …  linux  X4_Foundations  game  ldd X4 
./X4: /lib64/liblber-2.4.so.2: no version information available (required by ./X4)
./X4: /lib64/libldap_r-2.4.so.2: no version information available (required by ./X4)
./X4: lib/libssl.so.1.0.0: no version information available (required by ./X4)
./X4: lib/libssl.so.1.0.0: no version information available (required by ./X4)
./X4: lib/libcrypto.so.1.0.0: no version information available (required by ./X4)
linux-vdso.so.1 (0x00007ffed0b43000)
libstdc++.so.6 => /lib64/libstdc++.so.6 (0x00007fea9d4d8000)
libpthread.so.0 => /lib64/libpthread.so.0 (0x00007fea9d4b6000)
[...]


Doesn't matter from where you copy that lib as long as it matches the architecture and libc. It can be copied from Steam or any other application shipping this deprecated lib. F5 for example.

You need to Register and Login to comment, submit articles and more.


Or login with...