You can sign up to get a daily email of our articles, see the Mailing List page.
Using KDE Plasma Wayland session
Page: 1/2»
  Go to:
Shmerl 11 Nov
Tried switching to the Wayland session in Plasma 5.23.3 but it started hanging after monitor went to sleep. Back to X11 for now, but I guess it's worth digging into. Did anyone experience the same thing?

Last edited by Shmerl on 11 November 2021 at 6:09 am UTC
egon2003 11 Nov
I started using Wayland with Plasma 5.23 and it has worked decently. I have not had any hangs or freezes though but there are some annoyances compared to X11. I'm to lazy to switch back now since every time I switch back to X11 I have to set up my desktop again.
I would say its definitely usable now if you can live with some issues here and there.
Shmerl 11 Nov
What is your Mesa version (and amdgpu/kernel)? One of the downsides is that KWin is stuck with OpenGL / EGL. They should switch to Vulkan eventually.

Last edited by Shmerl on 11 November 2021 at 10:13 pm UTC
denyasis 11 Nov
Quoting: ShmerlDid anyone experience the same thing?

Yep! Just last week tried it. Same thing happens if you turn the monitor off.

Just got a black screen when I turned the monitor back on. I presumed a hang, as by the time it occurred to me to type out terminal commands to force a reboot, I'd already hit enough buttons on the keyboard I couldn't be sure what state the terminal was in to log in and issue commands blind.

Went back to X11. I'm pretty sure I've the same Plasma version over here in openSuse land. Honestly thought it was an OpenSuse/Nvidia thing as the implementation is a little rougher than in Debian.
Shmerl 11 Nov
Quoting: denyasis
Quoting: ShmerlDid anyone experience the same thing?

Yep! Just last week tried it. Same thing happens if you turn the monitor off.

We should probably file a bug for it, if there isn't one already. I just want to see what's in dmesg when that happens.
denyasis 11 Nov
Quoting: Shmerl
Quoting: denyasis
Quoting: ShmerlDid anyone experience the same thing?

Yep! Just last week tried it. Same thing happens if you turn the monitor off.

We should probably file a bug for it, if there isn't one already. I just want to see what's in dmesg when that happens.

That's a good idea! I'll see if I can try tonight and grab some log output.
The_Aquabat 12 Nov
For me plasmashell crashes a lot with Wayland, don't know if it is a problem of some app I'm using.
pete910 12 Nov
Don't have that issue though I'm on plasma 5.22.5 TBF wayland has been alot better thatn I thought it would be.

Only issue I have with wayland is the copy past bug thing !

It's what makes me default to X11 when not gaming .
Shmerl 13 Nov
Quoting: pete910Only issue I have with wayland is the copy past bug thing !

They fixed it in later versions.
pete910 14 Nov
Quoting: Shmerl
Quoting: pete910Only issue I have with wayland is the copy past bug thing !

They fixed it in later versions.

That's good to know !
egon2003 14 Nov
Quoting: ShmerlWhat is your Mesa version (and amdgpu/kernel)? One of the downsides is that KWin is stuck with OpenGL / EGL. They should switch to Vulkan eventually.

OpenGL renderer string: AMD Radeon RX 6800 XT (SIENNA_CICHLID, DRM 3.42.0, 5.15.2-gentoo-dist, LLVM 13.0.0)
OpenGL core profile version string: 4.6 (Core Profile) Mesa 21.3.0-rc3
While you're here, please consider supporting GamingOnLinux on:

Patreon, Liberapay or PayPal Donation.

This ensures all of our main content remains totally free for everyone with no article paywalls. We also don't have tons of adverts, there's also no tracking and we respect your privacy. Just good, fresh content. Without your continued support, we simply could not continue!

You can find even more ways to support us on this dedicated page any time. If you already are, thank you!
Login / Register

Or login with...
Sign in with Steam Sign in with Twitter Sign in with Google
Social logins require cookies to stay logged in.